summaryrefslogtreecommitdiff
path: root/dev-python/authres/authres-0.800.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/authres/authres-0.800.ebuild')
-rw-r--r--dev-python/authres/authres-0.800.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/authres/authres-0.800.ebuild b/dev-python/authres/authres-0.800.ebuild
new file mode 100644
index 00000000000..f1c5a0ea228
--- /dev/null
+++ b/dev-python/authres/authres-0.800.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Authentication Results Header Module"
+HOMEPAGE="https://launchpad.net/authentication-results-python http://pypi.python.org/pypi/authres"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE=""
+
+python_test() {
+ "${PYTHON}" -c "import sys, ${PN}, doctest; f, t = doctest.testfile('${PN}/tests'); \
+ sys.exit(bool(f))" || return
+}