summaryrefslogtreecommitdiff
path: root/dev-python/bcrypt/bcrypt-1.0.2-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/bcrypt/bcrypt-1.0.2-r1.ebuild')
-rw-r--r--dev-python/bcrypt/bcrypt-1.0.2-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/bcrypt/bcrypt-1.0.2-r1.ebuild b/dev-python/bcrypt/bcrypt-1.0.2-r1.ebuild
new file mode 100644
index 00000000000..235ca139f63
--- /dev/null
+++ b/dev-python/bcrypt/bcrypt-1.0.2-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Modern password hashing for software and servers"
+HOMEPAGE="https://github.com/dstufft/bcrypt/"
+SRC_URI="https://github.com/pyca/bcrypt/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="amd64 x86"
+IUSE="test"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}] )"
+RDEPEND="$(python_gen_cond_dep '>=dev-python/cffi-0.8:=[${PYTHON_USEDEP}]' python*)
+ !dev-python/py-bcrypt"
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_test() {
+ esetup.py test
+}