summaryrefslogtreecommitdiff
path: root/dev-python/bitstring/bitstring-3.1.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/bitstring/bitstring-3.1.1.ebuild')
-rw-r--r--dev-python/bitstring/bitstring-3.1.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/bitstring/bitstring-3.1.1.ebuild b/dev-python/bitstring/bitstring-3.1.1.ebuild
new file mode 100644
index 00000000000..a69fb64ff46
--- /dev/null
+++ b/dev-python/bitstring/bitstring-3.1.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+inherit distutils-r1
+
+DESCRIPTION="A pure Python module for creation and analysis of binary data"
+HOMEPAGE="http://python-bitstring.googlecode.com/"
+SRC_URI="http://python-bitstring.googlecode.com/files/${P}.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+python_test() {
+ if [[ ${EPYTHON} == python2.6 ]]; then
+ local runner=( unit2.py )
+ else
+ local runner=( "${PYTHON}" -m unittest )
+ fi
+ pushd test > /dev/null || die
+ "${runner[@]}" discover || die "Testing failed with ${EPYTHON}"
+ popd test > /dev/null || die
+}