summaryrefslogtreecommitdiff
path: root/dev-python/bottle/bottle-0.12.7.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/bottle/bottle-0.12.7.ebuild')
-rw-r--r--dev-python/bottle/bottle-0.12.7.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/bottle/bottle-0.12.7.ebuild b/dev-python/bottle/bottle-0.12.7.ebuild
new file mode 100644
index 00000000000..a2c658d2093
--- /dev/null
+++ b/dev-python/bottle/bottle-0.12.7.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="A fast and simple micro-framework for small web-applications"
+HOMEPAGE="http://pypi.python.org/pypi/bottle http://bottlepy.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+python_prepare_all() {
+ sed -i -e '/scripts/d' setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+pkg_postinst() {
+ elog "Due to problems with bottle.py being in /usr/bin (see bug #474874)"
+ elog "we do as most other distros and do not install the script anymore."
+ elog "If you do want/have to call it directly rather than through your app,"
+ elog "please use the following instead:"
+ elog ' `python -m bottle`'
+}