summaryrefslogtreecommitdiff
path: root/dev-python/celery/celery-4.0.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/celery/celery-4.0.2.ebuild')
-rw-r--r--dev-python/celery/celery-4.0.2.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/dev-python/celery/celery-4.0.2.ebuild b/dev-python/celery/celery-4.0.2.ebuild
index ba176e4ff47..83b0e06fec0 100644
--- a/dev-python/celery/celery-4.0.2.ebuild
+++ b/dev-python/celery/celery-4.0.2.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{4,5} )
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
inherit distutils-r1 bash-completion-r1
@@ -49,12 +49,16 @@ DEPEND="
>=dev-python/sphinx_celery-1.3[${PYTHON_USEDEP}]
dev-python/jinja[${PYTHON_USEDEP}]
dev-python/sqlalchemy[${PYTHON_USEDEP}]
- dev-python/typing[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/typing[${PYTHON_USEDEP}]' python2_7 python3_4)
)"
# testsuite needs it own source
DISTUTILS_IN_SOURCE_BUILD=1
+PATCHES=(
+ "${FILESDIR}"/${P}-log-endless-loop.patch
+ )
+
python_compile_all() {
if use doc; then
mkdir docs/.build || die