summaryrefslogtreecommitdiff
path: root/dev-python/clang-python/clang-python-6.0.9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/clang-python/clang-python-6.0.9999.ebuild')
-rw-r--r--dev-python/clang-python/clang-python-6.0.9999.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-python/clang-python/clang-python-6.0.9999.ebuild b/dev-python/clang-python/clang-python-6.0.9999.ebuild
index e0aa3318ebd..89b1f72d475 100644
--- a/dev-python/clang-python/clang-python-6.0.9999.ebuild
+++ b/dev-python/clang-python/clang-python-6.0.9999.ebuild
@@ -36,8 +36,12 @@ src_unpack() {
git-r3_checkout '' '' '' bindings/python
}
+python_test() {
+ "${EPYTHON}" -m unittest discover -v || die "Tests fail with ${EPYTHON}"
+}
+
src_test() {
- python_foreach_impl python -m unittest discover -v || die
+ python_foreach_impl python_test
}
src_install() {