summaryrefslogtreecommitdiff
path: root/dev-python/cli_helpers/cli_helpers-1.0.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/cli_helpers/cli_helpers-1.0.1.ebuild')
-rw-r--r--dev-python/cli_helpers/cli_helpers-1.0.1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/cli_helpers/cli_helpers-1.0.1.ebuild b/dev-python/cli_helpers/cli_helpers-1.0.1.ebuild
new file mode 100644
index 00000000000..34fa368a6ea
--- /dev/null
+++ b/dev-python/cli_helpers/cli_helpers-1.0.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+inherit distutils-r1
+
+DESCRIPTION="Python helpers for common CLI tasks"
+
+HOMEPAGE="http://cli-helpers.rtfd.io/"
+SRC_URI="https://github.com/dbcli/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="
+ >=dev-python/backports-csv-1.0[${PYTHON_USEDEP}]
+ >=dev-python/tabulate-0.8.0[${PYTHON_USEDEP}]
+ >=dev-python/terminaltables-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pygments-2.0[${PYTHON_USEDEP}]
+"