summaryrefslogtreecommitdiff
path: root/dev-python/ctypesgen
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/ctypesgen')
-rw-r--r--dev-python/ctypesgen/Manifest1
-rw-r--r--dev-python/ctypesgen/ctypesgen-0_p72-r1.ebuild38
-rw-r--r--dev-python/ctypesgen/ctypesgen-0_p72.ebuild25
-rw-r--r--dev-python/ctypesgen/metadata.xml5
4 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/ctypesgen/Manifest b/dev-python/ctypesgen/Manifest
new file mode 100644
index 00000000000..92a94955bcc
--- /dev/null
+++ b/dev-python/ctypesgen/Manifest
@@ -0,0 +1 @@
+DIST ctypesgen-0_p72.tar.bz2 85694 SHA256 1a43b7db43034fc88908c156ce701cb0a4c4f21b023f9e3fa46d488307c92b24 SHA512 eab85c71a2f98fd03ae582899de680bd861e7e6e20841ac087520f8b844dc686ea519b0510382cedec09ff3fa1d87fcc1c79878a2eb9219d7cc092423813e2e5 WHIRLPOOL b15e11d8d24280f4bdaf22fd3e6c8e13b36830e846774832ca584c0c816a0c814021ee95750b79df4a9ea701d99f0b1eda69f5e945a02184f788872aff409c95
diff --git a/dev-python/ctypesgen/ctypesgen-0_p72-r1.ebuild b/dev-python/ctypesgen/ctypesgen-0_p72-r1.ebuild
new file mode 100644
index 00000000000..242e09b05f6
--- /dev/null
+++ b/dev-python/ctypesgen/ctypesgen-0_p72-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python wrapper generator for ctypes"
+HOMEPAGE="http://code.google.com/p/ctypesgen/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+python_prepare_all() {
+ # r73 upstream
+ sed -i -e 's:libc:libm.so.6:' test/math_functions.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ cp -r -l test "${BUILD_DIR}"/ || die
+
+ cd "${BUILD_DIR}"/test || die
+ local f
+ for f in {math_functions,simple_macros,structures}.py; do
+ "${PYTHON}" "${f}" || die "Test ${f} fails with ${EPYTHON}"
+ done
+}
diff --git a/dev-python/ctypesgen/ctypesgen-0_p72.ebuild b/dev-python/ctypesgen/ctypesgen-0_p72.ebuild
new file mode 100644
index 00000000000..9fa93ee4528
--- /dev/null
+++ b/dev-python/ctypesgen/ctypesgen-0_p72.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+PYTHON_DEPEND="2:2.5"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+DESCRIPTION="Python wrapper generator for ctypes"
+HOMEPAGE="http://code.google.com/p/ctypesgen/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+# 2.4 restricted due to usage of ctypes module.
+RESTRICT_PYTHON_ABIS="2.4 3.*"
+
+PYTHON_MODNAME="ctypesgencore"
diff --git a/dev-python/ctypesgen/metadata.xml b/dev-python/ctypesgen/metadata.xml
new file mode 100644
index 00000000000..301d2207cc2
--- /dev/null
+++ b/dev-python/ctypesgen/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+</pkgmetadata>