summaryrefslogtreecommitdiff
path: root/dev-python/defusedxml/defusedxml-0.4.1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/defusedxml/defusedxml-0.4.1-r1.ebuild')
-rw-r--r--dev-python/defusedxml/defusedxml-0.4.1-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/defusedxml/defusedxml-0.4.1-r1.ebuild b/dev-python/defusedxml/defusedxml-0.4.1-r1.ebuild
new file mode 100644
index 00000000000..44a9452cb39
--- /dev/null
+++ b/dev-python/defusedxml/defusedxml-0.4.1-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="XML bomb protection for Python stdlib modules, an xml serialiser"
+HOMEPAGE="https://bitbucket.org/tiran/defusedxml"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+KEYWORDS="alpha amd64 arm hppa ~ppc64 x86"
+IUSE="examples"
+
+LICENSE="PSF-2"
+SLOT="0"
+
+python_test() {
+ esetup.py test || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( other/. )
+ distutils-r1_python_install_all
+}