summaryrefslogtreecommitdiff
path: root/dev-python/diff-match-patch/diff-match-patch-20121119.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/diff-match-patch/diff-match-patch-20121119.ebuild')
-rw-r--r--dev-python/diff-match-patch/diff-match-patch-20121119.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/diff-match-patch/diff-match-patch-20121119.ebuild b/dev-python/diff-match-patch/diff-match-patch-20121119.ebuild
new file mode 100644
index 00000000000..35d9c513165
--- /dev/null
+++ b/dev-python/diff-match-patch/diff-match-patch-20121119.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Diff, match and patch algorithms for plain text"
+HOMEPAGE="http://code.google.com/p/google-diff-match-patch/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+python_test() {
+ esetup.py test
+}