summaryrefslogtreecommitdiff
path: root/dev-python/dingus/dingus-0.3.4-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/dingus/dingus-0.3.4-r1.ebuild')
-rw-r--r--dev-python/dingus/dingus-0.3.4-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/dingus/dingus-0.3.4-r1.ebuild b/dev-python/dingus/dingus-0.3.4-r1.ebuild
new file mode 100644
index 00000000000..aaaeeee6350
--- /dev/null
+++ b/dev-python/dingus/dingus-0.3.4-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A record-then-assert mocking library"
+HOMEPAGE="http://pypi.python.org/pypi/dingus/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+KEYWORDS="amd64 x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+python_prepare_all() {
+ sed -i -e '/data_files/d' setup.py || die #413769
+ distutils-r1_python_prepare_all
+}