summaryrefslogtreecommitdiff
path: root/dev-python/dnspython/dnspython-1.12.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/dnspython/dnspython-1.12.0.ebuild')
-rw-r--r--dev-python/dnspython/dnspython-1.12.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/dnspython/dnspython-1.12.0.ebuild b/dev-python/dnspython/dnspython-1.12.0.ebuild
new file mode 100644
index 00000000000..7eb611adf1e
--- /dev/null
+++ b/dev-python/dnspython/dnspython-1.12.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="DNS toolkit for Python"
+HOMEPAGE="http://www.dnspython.org/ http://pypi.python.org/pypi/dnspython"
+SRC_URI="http://www.dnspython.org/kits/${PV}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+IUSE="examples test"
+
+DEPEND="dev-python/pycrypto[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+# For tests
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_test() {
+ pushd "${BUILD_DIR}"/../tests &> /dev/null
+ "${PYTHON}" utest.py || die "tests failed under ${EPYTHON}"
+ einfo "Testsuite passed under ${EPYTHON}"
+ popd &> /dev/null
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}