summaryrefslogtreecommitdiff
path: root/dev-python/docker-py/docker-py-1.3.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/docker-py/docker-py-1.3.0.ebuild')
-rw-r--r--dev-python/docker-py/docker-py-1.3.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/docker-py/docker-py-1.3.0.ebuild b/dev-python/docker-py/docker-py-1.3.0.ebuild
new file mode 100644
index 00000000000..03c6f387699
--- /dev/null
+++ b/dev-python/docker-py/docker-py-1.3.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Python client for Docker"
+HOMEPAGE="https://github.com/docker/docker-py"
+SRC_URI="https://github.com/docker/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( >=dev-python/mock-1.0.1[${PYTHON_USEDEP}] )
+"
+RDEPEND="
+ >=dev-python/requests-2.5.2[${PYTHON_USEDEP}]
+ >=dev-python/six-1.3.0[${PYTHON_USEDEP}]
+ >=dev-python/websocket-client-0.32.0[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ "${PYTHON}" tests/test.py || die "tests failed under ${EPYTHON}"
+}