summaryrefslogtreecommitdiff
path: root/dev-python/dynd-python/files/dynd-python-0.6.2-out-of-git-versioning.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/dynd-python/files/dynd-python-0.6.2-out-of-git-versioning.patch')
-rw-r--r--dev-python/dynd-python/files/dynd-python-0.6.2-out-of-git-versioning.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/dev-python/dynd-python/files/dynd-python-0.6.2-out-of-git-versioning.patch b/dev-python/dynd-python/files/dynd-python-0.6.2-out-of-git-versioning.patch
new file mode 100644
index 00000000000..29c3541b327
--- /dev/null
+++ b/dev-python/dynd-python/files/dynd-python-0.6.2-out-of-git-versioning.patch
@@ -0,0 +1,14 @@
+--- CMakeLists.txt.orig 2014-05-12 14:00:52.000000000 +0400
++++ CMakeLists.txt 2014-05-12 14:03:39.000000000 +0400
+@@ -86,8 +86,9 @@
+ endif()
+
+ # Get the git revision
+-get_git_head_revision("${CMAKE_CURRENT_SOURCE_DIR}" GIT_REFSPEC DYND_PYTHON_GIT_SHA1)
+-git_describe("${CMAKE_CURRENT_SOURCE_DIR}" DYND_PYTHON_VERSION_STRING --dirty --always --match "v*")
++SET(DYND_PYTHON_GIT_SHA1 "@DYND_PYTHON_GIT_SHA1@")
++SET(DYND_PYTHON_VERSION_STRING "@DYND_PYTHON_VERSION@")
++
+ message(STATUS "DyND-Python version: ${DYND_PYTHON_VERSION_STRING}")
+ configure_file(
+ "${CMAKE_CURRENT_SOURCE_DIR}/src/git_version.cpp.in"