summaryrefslogtreecommitdiff
path: root/dev-python/editobj/editobj-0.5.7-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/editobj/editobj-0.5.7-r1.ebuild')
-rw-r--r--dev-python/editobj/editobj-0.5.7-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/editobj/editobj-0.5.7-r1.ebuild b/dev-python/editobj/editobj-0.5.7-r1.ebuild
new file mode 100644
index 00000000000..050b48d98d4
--- /dev/null
+++ b/dev-python/editobj/editobj-0.5.7-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+PYTHON_DEPEND="2"
+PYTHON_USE_WITH="tk"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython 2.7-pypy-*"
+
+inherit distutils
+
+MY_P="${P/editobj/EditObj}"
+
+DESCRIPTION="EditObj can create a dialog box to edit ANY Python object"
+SRC_URI="http://download.gna.org/songwrite/${MY_P}.tar.gz"
+HOMEPAGE="http://home.gna.org/oomadness/en/editobj/index.html"
+
+LICENSE="GPL-2"
+KEYWORDS="amd64 ia64 ppc x86"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ distutils_src_install
+
+ insinto /usr/share/doc/${PF}
+ doins -r demo
+}