summaryrefslogtreecommitdiff
path: root/dev-python/edpwd/edpwd-0.0.7-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/edpwd/edpwd-0.0.7-r1.ebuild')
-rw-r--r--dev-python/edpwd/edpwd-0.0.7-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/edpwd/edpwd-0.0.7-r1.ebuild b/dev-python/edpwd/edpwd-0.0.7-r1.ebuild
new file mode 100644
index 00000000000..efb4d061423
--- /dev/null
+++ b/dev-python/edpwd/edpwd-0.0.7-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Encrypt/Decrypt Password Library that wraps up Blowfish"
+HOMEPAGE="https://pypi.python.org/pypi/edpwd/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=dev-python/setuptools-0.6.30[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/pycrypto[${PYTHON_USEDEP}]"
+
+python_test() {
+ set -- "${PYTHON}" setup.py test
+ echo "${@}"
+ "${@}" || die "Tests failed with ${EPYTHON}"
+}