summaryrefslogtreecommitdiff
path: root/dev-python/elementtree/elementtree-1.2.6-r3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/elementtree/elementtree-1.2.6-r3.ebuild')
-rw-r--r--dev-python/elementtree/elementtree-1.2.6-r3.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/elementtree/elementtree-1.2.6-r3.ebuild b/dev-python/elementtree/elementtree-1.2.6-r3.ebuild
new file mode 100644
index 00000000000..acdc6dce7c5
--- /dev/null
+++ b/dev-python/elementtree/elementtree-1.2.6-r3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+MY_P="${P}-20050316"
+
+DESCRIPTION="A light-weight XML object model for Python"
+HOMEPAGE="http://effbot.org/zone/element-index.htm http://pypi.python.org/pypi/elementtree"
+SRC_URI="http://effbot.org/downloads/${MY_P}.tar.gz"
+
+LICENSE="ElementTree"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 s390 sh sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+python_prepare_all() {
+ sed -e "s/distutils.core/setuptools/" -i setup.py || die "sed failed"
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ "${PYTHON}" selftest.py || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ local HTML_DOCS=( docs/. )
+ distutils-r1_python_install_all
+}