summaryrefslogtreecommitdiff
path: root/dev-python/fixtures/fixtures-1.3.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/fixtures/fixtures-1.3.0.ebuild')
-rw-r--r--dev-python/fixtures/fixtures-1.3.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/fixtures/fixtures-1.3.0.ebuild b/dev-python/fixtures/fixtures-1.3.0.ebuild
new file mode 100644
index 00000000000..4368613f0bf
--- /dev/null
+++ b/dev-python/fixtures/fixtures-1.3.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Fixtures, reusable state for writing clean tests and more"
+HOMEPAGE="https://launchpad.net/python-fixtures https://pypi.python.org/pypi/fixtures"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( Apache-2.0 BSD )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+# nose not listed but provides coverage output of tests
+# run of test files by python lacks any output except on fail
+RDEPEND="dev-python/pbr[${PYTHON_USEDEP}]
+ >=dev-python/testtools-0.9.22[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )"
+#DISTUTILS_IN_SOURCE_BUILD=1
+
+python_test() {
+ emake check
+}