summaryrefslogtreecommitdiff
path: root/dev-python/flask-socketio/flask-socketio-0.6.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/flask-socketio/flask-socketio-0.6.0.ebuild')
-rw-r--r--dev-python/flask-socketio/flask-socketio-0.6.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/flask-socketio/flask-socketio-0.6.0.ebuild b/dev-python/flask-socketio/flask-socketio-0.6.0.ebuild
new file mode 100644
index 00000000000..4348a53db7b
--- /dev/null
+++ b/dev-python/flask-socketio/flask-socketio-0.6.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+MY_PN="Flask-SocketIO"
+DESCRIPTION="Socket.IO integration for Flask applications."
+HOMEPAGE="https://flask-socketio.readthedocs.org/ https://github.com/miguelgrinberg/${MY_PN}/ https://pypi.python.org/pypi/${MY_PN}"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-python/flask-0.9[${PYTHON_USEDEP}]
+ >=dev-python/gevent-socketio-0.3.6[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+# pypi tarball does not contain tests
+RESTRICT="test"
+
+python_test() {
+ PYTHONPATH="${PWD}" python ./test_socketio.py || die
+}