summaryrefslogtreecommitdiff
path: root/dev-python/fonttools/fonttools-2.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/fonttools/fonttools-2.4.ebuild')
-rw-r--r--dev-python/fonttools/fonttools-2.4.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/fonttools/fonttools-2.4.ebuild b/dev-python/fonttools/fonttools-2.4.ebuild
new file mode 100644
index 00000000000..eeb2dc35649
--- /dev/null
+++ b/dev-python/fonttools/fonttools-2.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Library for manipulating TrueType, OpenType, AFM and Type1 fonts"
+HOMEPAGE="http://fonttools.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 arm ~arm64 ia64 ppc x86"
+IUSE=""
+
+DEPEND=">=dev-python/numpy-1.0.2[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+python_install_all() {
+ DOCS=( README.txt Doc/{changes.txt,install.txt} )
+ HTML_DOCS=( Doc/documentation.html )
+ distutils-r1_python_install_all
+}