summaryrefslogtreecommitdiff
path: root/dev-python/formencode/formencode-1.2.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/formencode/formencode-1.2.4.ebuild')
-rw-r--r--dev-python/formencode/formencode-1.2.4.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/formencode/formencode-1.2.4.ebuild b/dev-python/formencode/formencode-1.2.4.ebuild
new file mode 100644
index 00000000000..c8dec4e487c
--- /dev/null
+++ b/dev-python/formencode/formencode-1.2.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+MY_PN="FormEncode"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="HTML form validation, generation, and conversion package"
+HOMEPAGE="http://formencode.org/ http://pypi.python.org/pypi/FormEncode"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="amd64 ~ia64 ppc ~sparc x86 ~amd64-linux ~x86-linux ~x86-macos"
+IUSE=""
+
+DEPEND="dev-python/setuptools"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS="docs/*.txt"