summaryrefslogtreecommitdiff
path: root/dev-python/fpconst/fpconst-0.7.3-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/fpconst/fpconst-0.7.3-r1.ebuild')
-rw-r--r--dev-python/fpconst/fpconst-0.7.3-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/fpconst/fpconst-0.7.3-r1.ebuild b/dev-python/fpconst/fpconst-0.7.3-r1.ebuild
new file mode 100644
index 00000000000..c7bbe82303d
--- /dev/null
+++ b/dev-python/fpconst/fpconst-0.7.3-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python Module for handling IEEE 754 floating point special values"
+HOMEPAGE="http://chaco.bst.rochester.edu:8080/statcomp/projects/RStatServer/fpconst/ http://pypi.python.org/pypi/fpconst http://sourceforge.net/projects/rsoap/files/"
+SRC_URI="mirror://sourceforge/rsoap/${P}.tar.gz"
+
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+DOCS=( CHANGELOG README pep-0754.txt )
+
+python_test() {
+ "${PYTHON}" -m fpconst || die "Self-tests fail with ${EPYTHON}"
+}