summaryrefslogtreecommitdiff
path: root/dev-python/git-python/git-python-1.0.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/git-python/git-python-1.0.0.ebuild')
-rw-r--r--dev-python/git-python/git-python-1.0.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/git-python/git-python-1.0.0.ebuild b/dev-python/git-python/git-python-1.0.0.ebuild
new file mode 100644
index 00000000000..76d7ffb41e8
--- /dev/null
+++ b/dev-python/git-python/git-python-1.0.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+MY_PN="GitPython"
+MY_PV="${PV/_rc/.RC}"
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="Library used to interact with Git repositories"
+HOMEPAGE="http://gitorious.org/git-python http://pypi.python.org/pypi/GitPython"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+# Tests dont make sense without a git repo
+RESTRICT="test"
+
+RDEPEND="
+ dev-vcs/git
+ >=dev-python/gitdb-0.6.4[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )"
+# $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7 pypy)
+# is the correct entry for mock, however while RESTRICT="test"
+# there is little point in setting it since it is inactive
+S="${WORKDIR}/${MY_P}"