summaryrefslogtreecommitdiff
path: root/dev-python/gitdb/gitdb-0.6.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/gitdb/gitdb-0.6.3.ebuild')
-rw-r--r--dev-python/gitdb/gitdb-0.6.3.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/gitdb/gitdb-0.6.3.ebuild b/dev-python/gitdb/gitdb-0.6.3.ebuild
new file mode 100644
index 00000000000..2af816f66c5
--- /dev/null
+++ b/dev-python/gitdb/gitdb-0.6.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="GitDB is a pure-Python git object database"
+HOMEPAGE="
+ https://github.com/gitpython-developers/gitdb
+ http://pypi.python.org/pypi/gitdb"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-vcs/git
+ >=dev-python/smmap-0.8.5[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+# Testsuite appears to require files from a git repo
+
+python_compile() {
+ python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ distutils-r1_python_compile
+}