summaryrefslogtreecommitdiff
path: root/dev-python/guessit/guessit-0.6.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/guessit/guessit-0.6.2.ebuild')
-rw-r--r--dev-python/guessit/guessit-0.6.2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/guessit/guessit-0.6.2.ebuild b/dev-python/guessit/guessit-0.6.2.ebuild
new file mode 100644
index 00000000000..f6b015020a0
--- /dev/null
+++ b/dev-python/guessit/guessit-0.6.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_3} )
+
+inherit distutils-r1
+
+DESCRIPTION="library for guessing information from video files"
+HOMEPAGE="http://guessit.readthedocs.org https://github.com/wackou/guessit https://pypi.python.org/pypi/guessit"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ test? ( dev-python/pyyaml[${PYTHON_USEDEP}] )
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+# FIXME fails tests with python-3.3.2-r2
+RESTRICT="test"
+
+python_test() {
+ esetup.py test
+}