summaryrefslogtreecommitdiff
path: root/dev-python/hachoir-regex/hachoir-regex-1.0.5-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/hachoir-regex/hachoir-regex-1.0.5-r1.ebuild')
-rw-r--r--dev-python/hachoir-regex/hachoir-regex-1.0.5-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/hachoir-regex/hachoir-regex-1.0.5-r1.ebuild b/dev-python/hachoir-regex/hachoir-regex-1.0.5-r1.ebuild
new file mode 100644
index 00000000000..d3400ef6897
--- /dev/null
+++ b/dev-python/hachoir-regex/hachoir-regex-1.0.5-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Manipulation of regular expressions (regex)"
+HOMEPAGE="http://bitbucket.org/haypo/hachoir/wiki/hachoir-regex http://pypi.python.org/pypi/hachoir-regex"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+python_configure_all() {
+ mydistutilsargs=(
+ --setuptools
+ )
+}
+
+python_test() {
+ "${PYTHON}" test_doc.py || die "Tests fail with ${EPYTHON}"
+}