summaryrefslogtreecommitdiff
path: root/dev-python/hgtools/hgtools-6.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/hgtools/hgtools-6.0.ebuild')
-rw-r--r--dev-python/hgtools/hgtools-6.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/hgtools/hgtools-6.0.ebuild b/dev-python/hgtools/hgtools-6.0.ebuild
new file mode 100644
index 00000000000..9400a2ead3b
--- /dev/null
+++ b/dev-python/hgtools/hgtools-6.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Classes and setuptools plugin for Mercurial repositories"
+HOMEPAGE="https://bitbucket.org/jaraco/hgtools/"
+SRC_URI="mirror://pypi/h/${PN}/${P}.zip"
+
+LICENSE="GPL-2"
+KEYWORDS="amd64 x86"
+SLOT="0"
+IUSE="test"
+
+DEPEND="app-arch/unzip
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+RDEPEND="dev-vcs/mercurial"
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_test() {
+ pushd "${BUILD_DIR}"/../ > /dev/null
+ py.test "${PN}"/tests || die
+}