summaryrefslogtreecommitdiff
path: root/dev-python/http-parser/files/http-parser-0.7.8-setup.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/http-parser/files/http-parser-0.7.8-setup.patch')
-rw-r--r--dev-python/http-parser/files/http-parser-0.7.8-setup.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/http-parser/files/http-parser-0.7.8-setup.patch b/dev-python/http-parser/files/http-parser-0.7.8-setup.patch
new file mode 100644
index 00000000000..9bd43e6a153
--- /dev/null
+++ b/dev-python/http-parser/files/http-parser-0.7.8-setup.patch
@@ -0,0 +1,22 @@
+diff -ur http-parser-0.7.8.orig/setup.py http-parser-0.7.8/setup.py
+--- setup.py 2012-08-05 11:14:22.000000000 +0800
++++ setup.py 2013-01-21 01:54:23.748530621 +0800
+@@ -10,7 +10,7 @@
+ from distutils.command.sdist import sdist as _sdist
+ import glob
+ from imp import load_source
+-import os
++import os, io
+ import shutil
+ import sys
+ import traceback
+@@ -49,7 +49,7 @@
+ VERSION = http_parser.__version__
+
+ # get long description
+-with open(os.path.join(os.path.dirname(__file__), 'README.rst')) as f:
++with io.open(os.path.join(os.path.dirname(__file__), 'README.rst'), encoding='utf8') as f:
+ LONG_DESCRIPTION = f.read()
+
+ def _system(cmd):
+