summaryrefslogtreecommitdiff
path: root/dev-python/http-parser/http-parser-0.8.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/http-parser/http-parser-0.8.3.ebuild')
-rw-r--r--dev-python/http-parser/http-parser-0.8.3.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/http-parser/http-parser-0.8.3.ebuild b/dev-python/http-parser/http-parser-0.8.3.ebuild
new file mode 100644
index 00000000000..e12d9c20fa4
--- /dev/null
+++ b/dev-python/http-parser/http-parser-0.8.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="HTTP request/response parser for python in C"
+HOMEPAGE="http://github.com/benoitc/http-parser"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm ~ia64 ppc ppc64 ~s390 x86 ~x86-fbsd"
+IUSE="examples"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+cython_dep() {
+ local flag
+ for flag in $(python_gen_useflags 'python*'); do
+ DEPEND+=" ${flag}? ( dev-python/cython[${flag}(-)] )"
+ done
+}
+cython_dep
+
+python_compile() {
+ if [[ ${EPYTHON} != python3* ]]; then
+ local CFLAGS=${CFLAGS}
+ append-cflags -fno-strict-aliasing
+ fi
+
+ distutils-r1_python_compile
+}
+
+python_install_all() {
+ local DOCS=( README.rst )
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}