summaryrefslogtreecommitdiff
path: root/dev-python/httplib2/httplib2-0.8.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/httplib2/httplib2-0.8.ebuild')
-rw-r--r--dev-python/httplib2/httplib2-0.8.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/httplib2/httplib2-0.8.ebuild b/dev-python/httplib2/httplib2-0.8.ebuild
new file mode 100644
index 00000000000..38a38dd6cc7
--- /dev/null
+++ b/dev-python/httplib2/httplib2-0.8.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A comprehensive HTTP client library"
+HOMEPAGE="http://code.google.com/p/httplib2/ http://pypi.python.org/pypi/httplib2"
+SRC_URI="http://httplib2.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+# tests connect to random remote sites
+RESTRICT="test"
+
+python_test() {
+ if [[ ${EPYTHON} == python2.7 ]] ; then
+ cd python2 || die
+ else
+ cd python3 || die
+ fi
+
+ "${PYTHON}" httplib2test.py || die
+}