summaryrefslogtreecommitdiff
path: root/dev-python/jaraco-functools/jaraco-functools-1.11.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jaraco-functools/jaraco-functools-1.11.ebuild')
-rw-r--r--dev-python/jaraco-functools/jaraco-functools-1.11.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/jaraco-functools/jaraco-functools-1.11.ebuild b/dev-python/jaraco-functools/jaraco-functools-1.11.ebuild
new file mode 100644
index 00000000000..a3906db00d8
--- /dev/null
+++ b/dev-python/jaraco-functools/jaraco-functools-1.11.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+MY_PN="${PN/-/.}"
+DESCRIPTION="Additional functions used by other projects by developer jaraco"
+HOMEPAGE="https://github.com/jaraco/jaraco.functools"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/backports-functools-lru-cache[${PYTHON_USEDEP}]' python2_7)
+"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm-1.9[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ dev-python/backports-unittest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+python_test() {
+ PYTHONPATH=. py.test || die "tests failed with ${EPYTHON}"
+}