summaryrefslogtreecommitdiff
path: root/dev-python/jaraco-functools/jaraco-functools-1.8.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jaraco-functools/jaraco-functools-1.8.2.ebuild')
-rw-r--r--dev-python/jaraco-functools/jaraco-functools-1.8.2.ebuild44
1 files changed, 0 insertions, 44 deletions
diff --git a/dev-python/jaraco-functools/jaraco-functools-1.8.2.ebuild b/dev-python/jaraco-functools/jaraco-functools-1.8.2.ebuild
deleted file mode 100644
index 611ebeeb637..00000000000
--- a/dev-python/jaraco-functools/jaraco-functools-1.8.2.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_4,3_5} )
-
-inherit distutils-r1
-
-MY_PN="${PN/-/.}"
-DESCRIPTION="Additional functions used by other projects by developer jaraco"
-HOMEPAGE="https://github.com/jaraco/jaraco.functools"
-SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-RDEPEND="dev-python/six[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/backports-functools-lru-cache[${PYTHON_USEDEP}]' python2_7)
-"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-python/setuptools_scm-1.9[${PYTHON_USEDEP}]
- test? (
- ${RDEPEND}
- >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
- dev-python/pytest-runner[${PYTHON_USEDEP}]
- )
-"
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-python_prepare_all() {
- if use test && has_version "${CATEGORY}/${PN}"; then
- die "Ensure $PN is not already installed or the test suite will fail"
- fi
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- PYTHONPATH=. py.test || die "tests failed with ${EPYTHON}"
-}