summaryrefslogtreecommitdiff
path: root/dev-python/jsonfield/jsonfield-1.0.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jsonfield/jsonfield-1.0.3.ebuild')
-rw-r--r--dev-python/jsonfield/jsonfield-1.0.3.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/jsonfield/jsonfield-1.0.3.ebuild b/dev-python/jsonfield/jsonfield-1.0.3.ebuild
new file mode 100644
index 00000000000..91fe456e6aa
--- /dev/null
+++ b/dev-python/jsonfield/jsonfield-1.0.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Reusable Django field that allows you to store validated JSON in your model"
+HOMEPAGE="https://pypi.python.org/pypi/jsonfield https://github.com/bradjasper/django-jsonfield"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="test? ( dev-python/django[${PYTHON_USEDEP}] )"
+
+python_test() {
+ esetup.py test
+}