summaryrefslogtreecommitdiff
path: root/dev-python/keyring/keyring-1.6.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/keyring/keyring-1.6.1.ebuild')
-rw-r--r--dev-python/keyring/keyring-1.6.1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/keyring/keyring-1.6.1.ebuild b/dev-python/keyring/keyring-1.6.1.ebuild
new file mode 100644
index 00000000000..8007fe7727a
--- /dev/null
+++ b/dev-python/keyring/keyring-1.6.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 )
+
+inherit distutils-r1
+DESCRIPTION="Provides access to the system keyring service"
+HOMEPAGE="https://bitbucket.org/kang/python-keyring-lib"
+SRC_URI="mirror://pypi/k/${PN}/${P}.zip"
+
+LICENSE="PSF-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ app-arch/unzip
+ test? ( dev-python/pytest-runner[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pycrypto[${PYTHON_USEDEP}] )"
+RDEPEND=""
+
+python_prepare_all() {
+ sed -e s':from .py30compat:from keyring.tests.py30compat:' -i keyring/tests/test_util.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # test_backend.py and test_core.py access keyring backends
+ # which may spawn password prompts and do other damage.
+
+ # XXX: leave out the harmless tests (dummy backends?)
+ for t in test_{cli,util}.py; do
+ py.test "${BUILD_DIR}"/lib/${PN}/tests/${t} \
+ || die "${t} fails with ${EPYTHON}"
+ done
+}