summaryrefslogtreecommitdiff
path: root/dev-python/keyring/keyring-4.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/keyring/keyring-4.0.ebuild')
-rw-r--r--dev-python/keyring/keyring-4.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/keyring/keyring-4.0.ebuild b/dev-python/keyring/keyring-4.0.ebuild
new file mode 100644
index 00000000000..b3c8d2896fc
--- /dev/null
+++ b/dev-python/keyring/keyring-4.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Provides access to the system keyring service"
+HOMEPAGE="https://bitbucket.org/kang/python-keyring-lib"
+SRC_URI="mirror://pypi/k/${PN}/${P}.zip"
+
+SLOT="0"
+LICENSE="PSF-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pycrypto[$(python_gen_usedep 'python2*' 'python3*')]
+ )"
+RDEPEND=""
+
+python_test() {
+ py.test || die "testsuite failed under ${EPYTHON}"
+}