summaryrefslogtreecommitdiff
path: root/dev-python/libasyncns-python/libasyncns-python-0.7.1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/libasyncns-python/libasyncns-python-0.7.1-r1.ebuild')
-rw-r--r--dev-python/libasyncns-python/libasyncns-python-0.7.1-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/libasyncns-python/libasyncns-python-0.7.1-r1.ebuild b/dev-python/libasyncns-python/libasyncns-python-0.7.1-r1.ebuild
new file mode 100644
index 00000000000..0b0a6384b67
--- /dev/null
+++ b/dev-python/libasyncns-python/libasyncns-python-0.7.1-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for libasyncns"
+HOMEPAGE="https://launchpad.net/libasyncns-python/"
+SRC_URI="http://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=net-libs/libasyncns-0.4"
+RDEPEND="${DEPEND}"
+
+python_compile() {
+ if [[ ${EPYTHON} != python3* ]]; then
+ local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ fi
+ distutils-r1_python_compile
+}
+
+# Tests are network-dependent