summaryrefslogtreecommitdiff
path: root/dev-python/llvmmath/llvmmath-0.1.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/llvmmath/llvmmath-0.1.2.ebuild')
-rw-r--r--dev-python/llvmmath/llvmmath-0.1.2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/llvmmath/llvmmath-0.1.2.ebuild b/dev-python/llvmmath/llvmmath-0.1.2.ebuild
new file mode 100644
index 00000000000..8851209d1c7
--- /dev/null
+++ b/dev-python/llvmmath/llvmmath-0.1.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="LLVM math library for Python"
+HOMEPAGE="https://github.com/ContinuumIO/llvmmath"
+SRC_URI="https://github.com/ContinuumIO/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ dev-python/llvmpy[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.6[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_test() {
+ cd "${BUILD_DIR}"/lib* || die
+ ${PYTHON} -c 'import sys,llvmmath; sys.exit(llvmmath.test())' || die
+}