summaryrefslogtreecommitdiff
path: root/dev-python/louie/louie-1.1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/louie/louie-1.1-r1.ebuild')
-rw-r--r--dev-python/louie/louie-1.1-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/louie/louie-1.1-r1.ebuild b/dev-python/louie/louie-1.1-r1.ebuild
new file mode 100644
index 00000000000..fe1b263c3e7
--- /dev/null
+++ b/dev-python/louie/louie-1.1-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+MY_PN="Louie"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Signal dispatching mechanism for Python"
+HOMEPAGE="http://pypi.python.org/pypi/Louie"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+python_prepare_all() {
+ sed -e "/'nose >= 0.8.3'/d" -i setup.py || die "sed failed"
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests || die "Tests fail with ${EPYTHON}"
+}