summaryrefslogtreecommitdiff
path: root/dev-python/mkpythonproj/mkpythonproj-1.9.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/mkpythonproj/mkpythonproj-1.9.ebuild')
-rw-r--r--dev-python/mkpythonproj/mkpythonproj-1.9.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/mkpythonproj/mkpythonproj-1.9.ebuild b/dev-python/mkpythonproj/mkpythonproj-1.9.ebuild
new file mode 100644
index 00000000000..a332c12ef56
--- /dev/null
+++ b/dev-python/mkpythonproj/mkpythonproj-1.9.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Creates the framework for a new Python project or script"
+HOMEPAGE="http://www.seanet.com/~hgg9140/comp/mkpythonproj/doc/index.html"
+SRC_URI="http://www.seanet.com/~hgg9140/comp/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/. )
+ distutils-r1_python_install_all
+}