summaryrefslogtreecommitdiff
path: root/dev-python/myghtyutils/myghtyutils-0.52-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/myghtyutils/myghtyutils-0.52-r1.ebuild')
-rw-r--r--dev-python/myghtyutils/myghtyutils-0.52-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/myghtyutils/myghtyutils-0.52-r1.ebuild b/dev-python/myghtyutils/myghtyutils-0.52-r1.ebuild
new file mode 100644
index 00000000000..9a4e1e60a8d
--- /dev/null
+++ b/dev-python/myghtyutils/myghtyutils-0.52-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+MY_PN="MyghtyUtils"
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Set of utility classes used by Myghty templating"
+HOMEPAGE="http://www.myghty.org http://pypi.python.org/pypi/MyghtyUtils"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/myghty[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_P}"