summaryrefslogtreecommitdiff
path: root/dev-python/mypy/mypy-0.2.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/mypy/mypy-0.2.0.ebuild')
-rw-r--r--dev-python/mypy/mypy-0.2.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/mypy/mypy-0.2.0.ebuild b/dev-python/mypy/mypy-0.2.0.ebuild
new file mode 100644
index 00000000000..7d8aef31dfd
--- /dev/null
+++ b/dev-python/mypy/mypy-0.2.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python3_3 python3_4 )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Optional static typing for Python"
+HOMEPAGE="http://www.mypy-lang.org/"
+SRC_URI="https://github.com/JukkaL/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc examples"
+
+DEPEND="
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND=""
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ "${PYTHON}" tests.py || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+ use examples && local EXAMPLES=( samples/. )
+
+ distutils-r1_python_install_all
+}