summaryrefslogtreecommitdiff
path: root/dev-python/nautilus-python/nautilus-python-1.1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/nautilus-python/nautilus-python-1.1-r1.ebuild')
-rw-r--r--dev-python/nautilus-python/nautilus-python-1.1-r1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/nautilus-python/nautilus-python-1.1-r1.ebuild b/dev-python/nautilus-python/nautilus-python-1.1-r1.ebuild
new file mode 100644
index 00000000000..fd59a87fc1c
--- /dev/null
+++ b/dev-python/nautilus-python/nautilus-python-1.1-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+PYTHON_DEPEND="2"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit eutils gnome2 python
+
+DESCRIPTION="Python bindings for the Nautilus file manager"
+HOMEPAGE="http://projects.gnome.org/nautilus-python/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 x86"
+IUSE="doc"
+
+# Depend on pygobject:3 for sanity, and because it's automagic
+RDEPEND="dev-python/pygobject:3
+ >=gnome-base/nautilus-2.32[introspection]"
+DEPEND="${RDEPEND}
+ doc? (
+ app-text/docbook-xml-dtd:4.1.2
+ >=dev-util/gtk-doc-1.9 )"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_install() {
+ gnome2_src_install
+ # Directory for systemwide extensions
+ keepdir /usr/share/nautilus-python/extensions/
+ # Doesn't get installed by "make install" for some reason
+ if use doc; then
+ insinto /usr/share/gtk-doc/html/nautilus-python # for dev-util/devhelp
+ doins -r docs/html/*
+ fi
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ python_need_rebuild
+}