summaryrefslogtreecommitdiff
path: root/dev-python/ndg-httpsclient/ndg-httpsclient-0.3.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/ndg-httpsclient/ndg-httpsclient-0.3.2.ebuild')
-rw-r--r--dev-python/ndg-httpsclient/ndg-httpsclient-0.3.2.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/ndg-httpsclient/ndg-httpsclient-0.3.2.ebuild b/dev-python/ndg-httpsclient/ndg-httpsclient-0.3.2.ebuild
new file mode 100644
index 00000000000..62ce5425a0e
--- /dev/null
+++ b/dev-python/ndg-httpsclient/ndg-httpsclient-0.3.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Provides enhanced HTTPS support for httplib and urllib2 using PyOpenSSL"
+HOMEPAGE="http://ndg-security.ceda.ac.uk/wiki/ndg_httpsclient
+ https://pypi.python.org/pypi/ndg-httpsclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P/-/_}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE=""
+
+RDEPEND="dev-python/pyopenssl[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${P/-/_}"