summaryrefslogtreecommitdiff
path: root/dev-python/netcdf4-python/netcdf4-python-1.0.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/netcdf4-python/netcdf4-python-1.0.4.ebuild')
-rw-r--r--dev-python/netcdf4-python/netcdf4-python-1.0.4.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/netcdf4-python/netcdf4-python-1.0.4.ebuild b/dev-python/netcdf4-python/netcdf4-python-1.0.4.ebuild
new file mode 100644
index 00000000000..5d4bca9b4e7
--- /dev/null
+++ b/dev-python/netcdf4-python/netcdf4-python-1.0.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+MY_PN="netCDF4"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Python/numpy interface to netCDF"
+HOMEPAGE="https://code.google.com/p/netcdf4-python"
+SRC_URI="https://netcdf4-python.googlecode.com/files/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ sci-libs/hdf5
+ sci-libs/netcdf:=[hdf]"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"/${MY_P}
+
+python_test() {
+ cd test || die
+ ${PYTHON} run_all.py || die
+}