summaryrefslogtreecommitdiff
path: root/dev-python/objgraph/objgraph-1.8.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/objgraph/objgraph-1.8.1.ebuild')
-rw-r--r--dev-python/objgraph/objgraph-1.8.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/objgraph/objgraph-1.8.1.ebuild b/dev-python/objgraph/objgraph-1.8.1.ebuild
new file mode 100644
index 00000000000..d120aba9de8
--- /dev/null
+++ b/dev-python/objgraph/objgraph-1.8.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Draws Python object reference graphs with graphviz"
+HOMEPAGE="http://mg.pov.lt/objgraph/"
+SRC_URI="mirror://pypi/o/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64"
+SLOT="0"
+IUSE="doc"
+
+DEPEND=""
+RDEPEND="media-gfx/graphviz"
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/* )
+
+ distutils-r1_python_install_all
+}