summaryrefslogtreecommitdiff
path: root/dev-python/oct2py/oct2py-0.4.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/oct2py/oct2py-0.4.0-r1.ebuild')
-rw-r--r--dev-python/oct2py/oct2py-0.4.0-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/oct2py/oct2py-0.4.0-r1.ebuild b/dev-python/oct2py/oct2py-0.4.0-r1.ebuild
new file mode 100644
index 00000000000..ec8b85cd5d9
--- /dev/null
+++ b/dev-python/oct2py/oct2py-0.4.0-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python to GNU Octave bridge"
+HOMEPAGE="http://pypi.python.org/pypi/oct2py"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~ppc64 x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples test"
+
+RDEPEND="
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ sci-mathematics/octave"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_compile_all() {
+ if use doc; then
+ sphinx-build doc html || die
+ fi
+}
+
+python_test() {
+ nosetests || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( html/. )
+ distutils-r1_python_install_all
+
+ if use examples; then
+ insinto /usr/share/${PF}/
+ doins -r example
+ fi
+}