summaryrefslogtreecommitdiff
path: root/dev-python/openpyxl/openpyxl-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/openpyxl/openpyxl-9999.ebuild')
-rw-r--r--dev-python/openpyxl/openpyxl-9999.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/openpyxl/openpyxl-9999.ebuild b/dev-python/openpyxl/openpyxl-9999.ebuild
new file mode 100644
index 00000000000..7c2ec5391c9
--- /dev/null
+++ b/dev-python/openpyxl/openpyxl-9999.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+inherit distutils-r1 mercurial
+
+DESCRIPTION="Pure python reader and writer of Excel OpenXML files"
+HOMEPAGE="http://openpyxl.readthedocs.org"
+SRC_URI=""
+EHG_REPO_URI="https://bitbucket.org/openpyxl/openpyxl"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS=""
+IUSE="test"
+
+RDEPEND="dev-python/jdcal[${PYTHON_USEDEP}]"
+DEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ py.test || die "Testing failed with ${EPYTHON}"
+}