summaryrefslogtreecommitdiff
path: root/dev-python/paisley/paisley-0.3.1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/paisley/paisley-0.3.1-r1.ebuild')
-rw-r--r--dev-python/paisley/paisley-0.3.1-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/paisley/paisley-0.3.1-r1.ebuild b/dev-python/paisley/paisley-0.3.1-r1.ebuild
new file mode 100644
index 00000000000..a83a2687f23
--- /dev/null
+++ b/dev-python/paisley/paisley-0.3.1-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Paisley is a CouchDB client written in Python to be used within a Twisted application"
+HOMEPAGE="http://launchpad.net/paisley http://pypi.python.org/pypi/paisley"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/simplejson[${PYTHON_USEDEP}]
+ dev-python/twisted-core[${PYTHON_USEDEP}]
+ dev-python/twisted-web[${PYTHON_USEDEP}]"
+DEPEND="test? ( ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_test() {
+ nosetests || die "tests failed"
+}