summaryrefslogtreecommitdiff
path: root/dev-python/paisley/paisley-0.3.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/paisley/paisley-0.3.1.ebuild')
-rw-r--r--dev-python/paisley/paisley-0.3.1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/paisley/paisley-0.3.1.ebuild b/dev-python/paisley/paisley-0.3.1.ebuild
new file mode 100644
index 00000000000..cbdf944435f
--- /dev/null
+++ b/dev-python/paisley/paisley-0.3.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils
+
+DESCRIPTION="Paisley is a CouchDB client written in Python to be used within a Twisted application"
+HOMEPAGE="http://launchpad.net/paisley http://pypi.python.org/pypi/paisley"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+RDEPEND="dev-python/simplejson
+ dev-python/twisted-core
+ dev-python/twisted-web"
+DEPEND="${RDEPEND}"