summaryrefslogtreecommitdiff
path: root/dev-python/pexpect/pexpect-2.4-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pexpect/pexpect-2.4-r1.ebuild')
-rw-r--r--dev-python/pexpect/pexpect-2.4-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/pexpect/pexpect-2.4-r1.ebuild b/dev-python/pexpect/pexpect-2.4-r1.ebuild
new file mode 100644
index 00000000000..2496ff53f3e
--- /dev/null
+++ b/dev-python/pexpect/pexpect-2.4-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python module for spawning child applications and responding to expected patterns"
+HOMEPAGE="http://pexpect.sourceforge.net/ http://pypi.python.org/pypi/pexpect"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc examples"
+
+DEPEND=""
+RDEPEND=""
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/. )
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}